我创建了一个仅包含以下行的 .htaccess 文件:

选项-索引

但是,仍然显示该目录的索引。

我刚刚安装了 Apache2 并使用所有默认值(我没有修改 apache2.conf 或 httpd.conf)。

操作系统:Ubuntu 12.04 (Precise Pangolin)
阿帕奇2版本:Server version: Apache/2.2.22 (Ubuntu) Server built: Feb 13 2012 01:51:56

$ ls -l .htaccess
-rwxr-xr-x .htaccess

编辑:

我采纳了 lanzz 的建议并在其中添加了一些胡言乱语.htaccess文件,并发现.htaccess文件未被读取。

答案

为了使其正常工作,我添加了以下内容/etc/apache2/httpd.conf(安装Apache时默认是一个零长度文件)然后重新启动Apache。Options -Indexes在里面.htaccess文件按预期工作。

/etc/apache2/httpd.conf :

<VirtualHost *:80>
        DocumentRoot /var/www
        <Directory / >
        </Directory>
</VirtualHost>

兰兹建议添加一行乱码.htaccess文件以查看它是否正在被读取有助于诊断问题。

注意AllowOveride默认为All, 每埃文·穆拉夫斯基的注释,因此在最小集合中不需要它httpd.conf上面的行。

来自: stackoverflow.com